summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Moore <pmoore@redhat.com>2014-04-23 15:50:10 -0400
committerPaul Moore <pmoore@redhat.com>2014-04-29 14:53:28 -0400
commitfd42fda82ff0732b1b43b738eb0c5dda1381d2e0 (patch)
tree130126aad7bb488e7b32b674e6075e8333caceda /configure.ac
parente460e96512ebe1a52770cfe4a728b77c70b05443 (diff)
downloadlibseccomp-fd42fda82ff0732b1b43b738eb0c5dda1381d2e0.tar.gz
build: general cleanup and reorganization of the autotools configuration
Signed-off-by: Paul Moore <pmoore@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5df8be5..b6788ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,6 @@ m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
AC_DISABLE_STATIC
LT_INIT
-AC_CHECK_HEADER([linux/seccomp.h])
AM_CPPFLAGS="-I\${top_srcdir}/include"
AM_CFLAGS="-Wall"
@@ -25,6 +24,11 @@ AC_SUBST([AM_CFLAGS])
AC_SUBST([AM_LDFLAGS])
dnl ####
+dnl check build system seccomp awareness
+dnl ####
+AC_CHECK_HEADERS_ONCE([linux/seccomp.h])
+
+dnl ####
dnl version information
dnl ####
VERSION_MAJOR=$(echo ${VERSION} | cut -d'.' -f 1)
@@ -77,10 +81,12 @@ dnl makefiles
dnl ####
AC_CONFIG_FILES([
Makefile
+ include/Makefile
src/Makefile
src/python/Makefile
tools/Makefile
tests/Makefile
+ doc/Makefile
])
dnl ####