summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@inai.de>2013-06-18 03:55:08 +0200
committerPaul Moore <pmoore@redhat.com>2014-04-29 13:52:05 -0400
commitc92404d08090a67a019776d5478f4dd615306968 (patch)
treea83d0b89d51e6139569ede36d6c78602e46078f1 /src/Makefile.am
parenteca0c1ecb7b7f7a0d390b3c84f0099f8ce688f27 (diff)
downloadlibseccomp-c92404d08090a67a019776d5478f4dd615306968.tar.gz
build: initial attempt to use autotools as the build system
With my apologies to Jan for delaying this patch for so long, there are a number of differences between Jan's original patch and what is being merged in this patch; almost all of the changes are due to changes in the underlying code base, but there are a few minor fixes as well. Signed-off-by: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Paul Moore <pmoore@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..61e421b
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,17 @@
+# -*- Makefile -*-
+
+SUBDIRS = .
+if ENABLE_PYTHON
+SUBDIRS += python
+endif
+
+lib_LTLIBRARIES = libseccomp.la
+
+libseccomp_la_SOURCES = api.c arch.c arch-x86.c arch-x86-syscalls.c \
+ arch-x86_64.c arch-x86_64-syscalls.c arch-x32.c arch-x32-syscalls.c \
+ arch-arm.c arch-arm-syscalls.c arch-mips.c arch-mips-syscalls.c \
+ db.c hash.c gen_pfc.c gen_bpf.c \
+ \
+ arch-mips.h arch-arm.h arch-x32.h arch-x86.h arch-x86_64.h arch.h \
+ db.h gen_bpf.h gen_pfc.h hash.h system.h
+libseccomp_la_LDFLAGS = -version-number 2:1:0