summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPaul Moore <pmoore@redhat.com>2014-04-22 17:35:59 -0400
committerPaul Moore <pmoore@redhat.com>2014-04-29 14:53:28 -0400
commite460e96512ebe1a52770cfe4a728b77c70b05443 (patch)
tree9af3430fae8534db4293a3c5f9b8b0db1bf11174 /src/Makefile.am
parent45b7b49a04eafb544e4bd1768b46a407fc696ff9 (diff)
downloadlibseccomp-e460e96512ebe1a52770cfe4a728b77c70b05443.tar.gz
build: cleanup version dependent aspects of the autotools build
Signed-off-by: Paul Moore <pmoore@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 61e421b..3148e8c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -14,4 +14,5 @@ libseccomp_la_SOURCES = api.c arch.c arch-x86.c arch-x86-syscalls.c \
\
arch-mips.h arch-arm.h arch-x32.h arch-x86.h arch-x86_64.h arch.h \
db.h gen_bpf.h gen_pfc.h hash.h system.h
-libseccomp_la_LDFLAGS = -version-number 2:1:0
+libseccomp_la_LDFLAGS = \
+ -version-number ${VERSION_MAJOR}:${VERSION_MINOR}:${VERSION_MICRO}