summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTom Hromatka <tom.hromatka@oracle.com>2019-11-15 12:55:33 -0700
committerPaul Moore <paul@paul-moore.com>2020-02-28 08:40:15 -0500
commit38f04da8474855f6ca850cc70e389bd56dbbf2fe (patch)
tree98d688354325cd851ae63b3ca5d9a2e61813bb9f /tests/Makefile.am
parenta3732b32b8e67a5c466a625f0e1e0d0bfde5ee0b (diff)
downloadlibseccomp-38f04da8474855f6ca850cc70e389bd56dbbf2fe.tar.gz
tests: add tests for the binary tree
This commit adds tests to ensure the validity of the binary tree and the resultant pfc and bpf output. Signed-off-by: Tom Hromatka <tom.hromatka@oracle.com> Signed-off-by: Paul Moore <paul@paul-moore.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 406d5a1..4bd19c8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -91,7 +91,10 @@ check_PROGRAMS = \
49-sim-64b_comparisons \
50-sim-hash_collision \
51-live-user_notification \
- 52-basic-load
+ 52-basic-load \
+ 53-sim-binary_tree \
+ 54-live-binary_tree \
+ 55-basic-pfc_binary_tree
EXTRA_DIST_TESTPYTHON = \
util.py \
@@ -145,7 +148,9 @@ EXTRA_DIST_TESTPYTHON = \
49-sim-64b_comparisons.py \
50-sim-hash_collision.py \
51-live-user_notification.py \
- 52-basic-load.py
+ 52-basic-load.py \
+ 53-sim-binary_tree.py \
+ 54-live-binary_tree.py
EXTRA_DIST_TESTCFGS = \
01-sim-allow.tests \
@@ -199,10 +204,14 @@ EXTRA_DIST_TESTCFGS = \
49-sim-64b_comparisons.tests \
50-sim-hash_collision.tests \
51-live-user_notification.tests \
- 52-basic-load.tests
+ 52-basic-load.tests \
+ 53-sim-binary_tree.tests \
+ 54-live-binary_tree.tests \
+ 55-basic-pfc_binary_tree.tests
EXTRA_DIST_TESTSCRIPTS = \
- 38-basic-pfc_coverage.sh 38-basic-pfc_coverage.pfc
+ 38-basic-pfc_coverage.sh 38-basic-pfc_coverage.pfc \
+ 55-basic-pfc_binary_tree.sh 55-basic-pfc_binary_tree.pfc
EXTRA_DIST_TESTTOOLS = regression testdiff testgen