summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPaul Moore <pmoore@redhat.com>2014-04-23 11:41:37 -0400
committerPaul Moore <pmoore@redhat.com>2014-05-01 14:12:41 -0400
commit3b82469ed95797372d9ec5515cf1518ac4f0b5c8 (patch)
tree03c052cfe1fec8a06977e4432daf0b78b2099342 /tests/Makefile.am
parentbb34e96b15a6c8928cabccc2418ef904c24368eb (diff)
downloadlibseccomp-3b82469ed95797372d9ec5515cf1518ac4f0b5c8.tar.gz
build: regression test fixes
Signed-off-by: Paul Moore <pmoore@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7d76267..5a9a112 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -9,11 +9,7 @@ util_la_LDFLAGS = -module
TESTS = regression
-EXTRA_DIST = regression *.tests
-BUILT_SOURCES = 00-test.c
-
check_PROGRAMS = \
- 00-test \
01-sim-allow \
02-sim-basic \
03-sim-basic_chains \
@@ -41,5 +37,7 @@ check_PROGRAMS = \
25-sim-multilevel_chains_adv \
26-sim-arch_all_be_basic
-00-test.c:
- if ! test -e $@; then echo "int main(void) { return 0; }" >$@; fi
+EXTRA_PROGRAMS = 00-test
+
+clean-local:
+ ${RM} -f 00-test