summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTom Hromatka <tom.hromatka@oracle.com>2018-04-05 17:39:21 -0400
committerPaul Moore <paul@paul-moore.com>2018-04-05 17:39:21 -0400
commit475f67ccd5814d94c935e76d3aeb743ce257f2d3 (patch)
treedf34c59ddeaa15561941b739ee1cf40ba7584b3d /tests/Makefile.am
parent0f03fdf63d5a33ed1a9b0e9e8dbdd4311aa3c48f (diff)
downloadlibseccomp-475f67ccd5814d94c935e76d3aeb743ce257f2d3.tar.gz
tests: add tests for db_chain_lt()
Add a test to improve the test coverage for db_chain_lt(). Signed-off-by: Tom Hromatka <tom.hromatka@oracle.com> [PM: stripped the conversion from a macro to function, kept the test] Signed-off-by: Paul Moore <paul@paul-moore.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 844c403..6cd8130 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -83,7 +83,8 @@ check_PROGRAMS = \
41-sim-syscall_priority_arch \
42-sim-adv_chains \
43-sim-a2_order \
- 44-live-a2_order
+ 44-live-a2_order \
+ 45-sim-chain_code_coverage
EXTRA_DIST_TESTPYTHON = \
util.py \
@@ -128,7 +129,8 @@ EXTRA_DIST_TESTPYTHON = \
41-sim-syscall_priority_arch.py \
42-sim-adv_chains.py \
43-sim-a2_order.py \
- 44-live-a2_order.py
+ 44-live-a2_order.py \
+ 45-sim-chain_code_coverage.py
EXTRA_DIST_TESTCFGS = \
01-sim-allow.tests \
@@ -174,7 +176,8 @@ EXTRA_DIST_TESTCFGS = \
41-sim-syscall_priority_arch.tests \
42-sim-adv_chains.tests \
43-sim-a2_order.tests \
- 44-live-a2_order.tests
+ 44-live-a2_order.tests \
+ 45-sim-chain_code_coverage.tests
EXTRA_DIST_TESTSCRIPTS = \
38-basic-pfc_coverage.sh 38-basic-pfc_coverage.pfc