summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMathias Krause <minipli@googlemail.com>2015-07-15 22:32:12 +0200
committerPaul Moore <pmoore@redhat.com>2015-07-16 22:06:35 -0400
commitbfac175ac1222ca59045eeecd8d27df9dd7bab4d (patch)
treefc2e7872e53799a40c3a0b77fcc7a4493f58b827 /tests/Makefile.am
parentb104193d48d479b7e342c292ddcae0133575f68a (diff)
downloadlibseccomp-bfac175ac1222ca59045eeecd8d27df9dd7bab4d.tar.gz
tests: fix sequence number generation
Because of incorrect number sequence generation by seq(1) on at least 32 bit ARM systems using coreutils v8.23/v8.24 we provide a minimal seq(1) implementation that fits our needs. This fixes the bug mentioned in the following mailing thread: https://groups.google.com/forum/#!topic/libseccomp/VtrClkXxLGA Signed-off-by: Mathias Krause <minipli@googlemail.com> [PM: subject line, build locations, and vertical whitespace tweaks] Signed-off-by: Paul Moore <pmoore@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 25cef75..b2863bb 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -26,6 +26,7 @@ util_la_LDFLAGS = -module
TESTS = regression
check_PROGRAMS = \
+ miniseq \
01-sim-allow \
02-sim-basic \
03-sim-basic_chains \