summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPaul Moore <pmoore@redhat.com>2014-05-07 12:05:59 -0400
committerPaul Moore <pmoore@redhat.com>2014-05-07 12:05:59 -0400
commite8a449fb5b87ba0479524b661fe962a5d977d400 (patch)
tree477d8c82acf2beeca1224b3a473967ac13b83c8c /tests/Makefile.am
parent430419e312ceb7c3ca1255b97c8b4ec0151e8bb3 (diff)
downloadlibseccomp-e8a449fb5b87ba0479524b661fe962a5d977d400.tar.gz
build: create a 'check-build' target
Sometimes it is helpful to build the test without executing them, add a new target, 'check-build' to do just that. Signed-off-by: Paul Moore <pmoore@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7cda78b..d50e29b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -55,5 +55,8 @@ check_PROGRAMS = \
EXTRA_PROGRAMS = 00-test
+check-build:
+ ${MAKE} ${AM_MAKEFLAGS} ${check_PROGRAMS}
+
clean-local:
${RM} -f 00-test *.pyc