summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 29ee2ec..48078e0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,8 +37,19 @@ check-build: all
check-syntax:
@./tools/check-syntax
+if CODE_COVERAGE_ENABLED
check-code-coverage: check-build
${MAKE} ${AM_MAKEFLAGS} -C tests check-code-coverage
+endif
+
+if CODE_COVERAGE_ENABLED
+test-code-coverage: check-build
+ ${MAKE} ${AM_MAKEFLAGS} -C src check-code-coverage
+ LIBSECCOMP_TSTCFG_TYPE=basic \
+ ${MAKE} ${AM_MAKEFLAGS} check-code-coverage
+ LIBSECCOMP_TSTCFG_TYPE=bpf-sim \
+ ${MAKE} ${AM_MAKEFLAGS} check-code-coverage
+endif
if COVERITY
coverity-build: clean