summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4709b78..7fe0787 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,3 +34,20 @@ check-build: all
check-syntax:
@./tools/check-syntax
+
+if COVERITY
+coverity-build: clean
+ cov-build --dir cov-int ${MAKE} ${AM_MAKEFLAGS} check-build
+endif
+
+if COVERITY
+coverity-tarball: coverity-build
+ @git rev-parse HEAD &> /dev/null && \
+ rev=$$(git rev-parse HEAD | cut -c1-8) || \
+ rev=$$(date --iso-8601=date); \
+ tar czf libseccomp-coverity_$$rev.tar.gz cov-int; \
+ ls -l libseccomp-coverity_$$rev.tar.gz
+endif
+
+clean-local:
+ ${RM} -rf cov-int libseccomp-coverity_*.tar.gz