summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Garcia Campos <cgarcia@igalia.com>2022-07-27 15:19:00 +0200
committerCarlos Garcia Campos <cgarcia@igalia.com>2022-08-12 12:20:02 +0200
commit261cbad7cf9134ba5b63983ccbc61834724ae5ab (patch)
treeeb59de7994aef8aeeadb3851d558be86640d126e /meson.build
parent5fb25e7810498170dd3458c9509035cef945e299 (diff)
downloadlibsoup-261cbad7cf9134ba5b63983ccbc61834724ae5ab.tar.gz
tests: use SoupServer instead of quart for HTTP/2 tests
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build21
1 files changed, 1 insertions, 20 deletions
diff --git a/meson.build b/meson.build
index e7db3a25..9509f813 100644
--- a/meson.build
+++ b/meson.build
@@ -285,27 +285,9 @@ else
have_autobahn = find_program('wstest', required: get_option('autobahn')).found()
endif
-# Quart server used for HTTP/2 tests
-quart_found = false
-
-if not get_option('http2_tests').disabled()
- pymod = import('python')
- python = pymod.find_installation('python3')
- if python.found()
- ret = run_command(python, '-c', 'import importlib\nassert(importlib.find_loader("quart"))', check: false)
- if ret.returncode() == 0
- quart_found = true
- endif
- endif
- message('Python module quart found: @0@'.format(quart_found.to_string('YES', 'NO')))
- if get_option('http2_tests').enabled() and not quart_found
- error('quart is required for http2 tests')
- endif
-endif
-
gnutls_dep = dependency('gnutls', version: '>= 3.6.0', required : get_option('pkcs11_tests'))
-if not have_apache or not quart_found or not have_autobahn or not gnutls_dep.found()
+if not have_apache or not have_autobahn or not gnutls_dep.found()
warning('Some regression tests will not be compiled due to missing libraries or modules. Please check the logs for more details.')
endif
@@ -431,7 +413,6 @@ summary({
summary({
'All tests' : get_option('tests'),
'Tests requiring Apache' : have_apache,
- 'Tests requiring Quart' : quart_found,
'Documentation tests' : get_option('doc_tests'),
'Fuzzing tests' : get_option('fuzzing').enabled(),
'Autobahn tests' : have_autobahn,