summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@codelibre.net>2021-02-06 22:43:15 +0000
committerRoger Leigh <rleigh@codelibre.net>2021-02-13 12:24:53 +0000
commit4738634f02ed2f6a383b1540168373a9df809c8e (patch)
tree684c2d06809ae84db70f622bfe35ad51ae50099f /CMakeLists.txt
parentfc96f83a0f7a69e3e4c2d74952331b3bac7568ea (diff)
downloadlibtiff-git-4738634f02ed2f6a383b1540168373a9df809c8e.tar.gz
cmake: Move Win32 IO feature to WindowsIOFeature.cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fa5c2275..3eb479ed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -315,13 +315,7 @@ check_include_file(GLUT/glut.h HAVE_GLUT_GLUT_H)
check_include_file(OpenGL/gl.h HAVE_OPENGL_GL_H)
check_include_file(OpenGL/glu.h HAVE_OPENGL_GLU_H)
-# Win32 IO
-set(win32_io FALSE)
-if(WIN32)
- set(win32_io TRUE)
-endif()
-
-set(USE_WIN32_FILEIO ${win32_io})
+include(WindowsIOFeature)
# Orthogonal features