summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@codelibre.net>2022-05-30 07:21:53 +0100
committerRoger Leigh <rleigh@codelibre.net>2022-06-04 20:53:23 +0100
commit21ae5bbb020fe649d8059079ebb1c2def8aef6a4 (patch)
treed54791ff4a49308c441b594f0d1930fd428d413b /configure.ac
parent9ba9c66ccaed95abc4be074801ecd7fdf058fb37 (diff)
downloadlibtiff-git-21ae5bbb020fe649d8059079ebb1c2def8aef6a4.tar.gz
Convert HTML documentation to Sphinx RST
* Add CMake build logic * Add Autotools build logic * Move from html/ to doc/ * Manual pages are still generated HTML for the time being
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 16 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7706011b..a5b1e811 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1093,8 +1093,23 @@ if test "$CHECK_JPEG_YCBCR_SUBSAMPLING" = "yes" ; then
[Pick up YCbCr subsampling info from the JPEG data stream to support files lacking the tag (default enabled).])
fi
+
+AC_ARG_ENABLE(sphinx,
+ AS_HELP_STRING([--disable-sphinx],
+ [disable building of the sphinx documentation]),
+ [BUILD_SPHINX=$enableval],
+ [BUILD_SPHINX=yes])
+
+
+
+AC_PATH_PROG(SPHINX_BUILD, [sphinx-build], [no])
+
+AM_CONDITIONAL([SPHINX], [test "$BUILD_SPHINX" = yes -a "$SPHINX_BUILD" != no])
+
+
dnl ---------------------------------------------------------------------------
+
AC_SUBST(LIBDIR)
AC_CONFIG_HEADERS([config/config.h libtiff/tif_config.h libtiff/tiffconf.h port/libport_config.h])
@@ -1112,9 +1127,7 @@ AC_CONFIG_FILES([Makefile \
contrib/stream/Makefile \
contrib/tags/Makefile \
contrib/win_dib/Makefile \
- html/Makefile \
- html/images/Makefile \
- html/man/Makefile \
+ doc/Makefile \
libtiff-4.pc \
libtiff/Makefile \
man/Makefile \