summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBob Friesenhahn <bfriesen@simple.dallas.tx.us>2012-08-19 16:56:32 +0000
committerBob Friesenhahn <bfriesen@simple.dallas.tx.us>2012-08-19 16:56:32 +0000
commit7d38024b8da8e2fe0b651be3e0b89380e110381e (patch)
treec40551d2437b378867f8a344a3c97f453a710149 /configure.ac
parentd85a64b6d6379c9f9b8de6ff3a26e380b0fc3e18 (diff)
downloadlibtiff-git-7d38024b8da8e2fe0b651be3e0b89380e110381e.tar.gz
* libtiff{tiff.h, tif_print.c, tif_dirinfo.c, tif_dirread.c}: Add
some TIFF/FX support in libtiff. Add the tag definitions to tiff.h. Add the related TIFF field definitions to tif_dirinfo.c, and also fixes an error in a comment. Adds the photometric values to tif_print.c, and fixes a bug. These changes are by Steve Underwood. * libtiff/tif_write.c: Fix bug rewriting image tiles in a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1405eb57..08757f1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,9 +154,6 @@ LT_LANG([C++])
# Enable support for silent build rules
AM_SILENT_RULES
-dnl Checks for libraries.
-AC_CHECK_LIB([c], [main])
-
dnl We don't need to add math library to all targets
case "${host_os}" in
cygwin* | mingw32* | beos* | darwin*)
@@ -813,10 +810,17 @@ dnl ---------------------------------------------------------------------------
HAVE_OPENGL=no
+
AC_PATH_XTRA
+dnl AX_CHECK_GL sets GL_CFLAGS & GL_LIBS. Also PTHREAD_LIBS,
+dnl PTHREAD_CFLAGS, & PTHREAD_CC as a side-effect
AX_CHECK_GL
+
+dnl AX_CHECK_GLU sets GLU_CFLAGS & GLU_LIBS
AX_CHECK_GLU
+
+dnl AX_CHECK_GLUT sets GLUT_CFLAGS & GLUT_LIBS
AX_CHECK_GLUT
if test "$no_x" != "yes" -a "$no_gl" != "yes" \