summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrank Warmerdam <warmerdam@pobox.com>2011-02-18 20:53:04 +0000
committerFrank Warmerdam <warmerdam@pobox.com>2011-02-18 20:53:04 +0000
commit82361dfa04e1be95c02bd3a81c8ec4815410f92a (patch)
tree620745233e685fd22e6cfa7a4426916ea14af497 /configure.ac
parent29beec44d2483599f1a8cf5d8db18c3218b8ddba (diff)
downloadlibtiff-git-82361dfa04e1be95c02bd3a81c8ec4815410f92a.tar.gz
implement optional support for deferred strip/tile offset/size loading
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fd4fcb4e..ed398a56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -839,6 +839,22 @@ if test "$HAVE_STRIPCHOP" = "yes" \
fi
dnl ---------------------------------------------------------------------------
+dnl Should we try to defer loading of strip/tile offsets and sizes to
+dnl optimize directory scanning? These is an experimental feature for
+dnl libtiff 4.0.
+dnl ---------------------------------------------------------------------------
+
+AC_ARG_ENABLE(defer-strile-load,
+ AS_HELP_STRING([--enable-defer-strile-load],
+ [enable deferred strip/tile offset/size loading (experimental)]),
+ [HAVE_DEFER_STRILE_LOAD=$enableval], [HAVE_DEFER_STRILE_LOAD=no])
+
+if test "$HAVE_DEFER_STRILE_LOAD" = "yes" ; then
+ AC_DEFINE(DEFER_STRILE_LOAD,1,[enable deferred strip/tile offset/size loading (experimental)])
+
+fi
+
+dnl ---------------------------------------------------------------------------
dnl Default subifd support.
dnl ---------------------------------------------------------------------------
AC_DEFINE(SUBIFD_SUPPORT,1,[Enable SubIFD tag (330) support])