summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBob Friesenhahn <bfriesen@simple.dallas.tx.us>2015-06-21 18:46:29 +0000
committerBob Friesenhahn <bfriesen@simple.dallas.tx.us>2015-06-21 18:46:29 +0000
commitbdd91bbdf8d5757c2d2d0e478ccd69a04ab77a15 (patch)
tree71915ece798e883be80e47a3bee49ad0a3b4dc16 /configure.ac
parent37c8b068e1d6d647ac5a293c9cc97e34396a71da (diff)
downloadlibtiff-git-bdd91bbdf8d5757c2d2d0e478ccd69a04ab77a15.tar.gz
* configure.ac: Add a HAVE_FOO Automake conditional for each
add-on library. * test/Makefile.am (JPEG_DEPENDENT_CHECK_PROG): raw_decode requires JPEG support to compile. Use Automake conditional to only include it when JPEG support is available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7851956c..5448dc07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -688,6 +688,8 @@ if test "$HAVE_JPEG" = "yes" ; then
fi
+AM_CONDITIONAL(HAVE_JPEG, test "$HAVE_JPEG" = 'yes')
+
dnl ---------------------------------------------------------------------------
dnl Check for Old JPEG.
dnl ---------------------------------------------------------------------------
@@ -760,6 +762,8 @@ if test "$HAVE_JBIG" = "yes" ; then
fi
+AM_CONDITIONAL(HAVE_JBIG, test "$HAVE_JBIG" = 'yes')
+
dnl ---------------------------------------------------------------------------
dnl Check for liblzma2.
dnl ---------------------------------------------------------------------------
@@ -812,6 +816,8 @@ if test "$HAVE_LZMA" = "yes" ; then
fi
+AM_CONDITIONAL(HAVE_LZMA, test "$HAVE_LZMA" = 'yes')
+
dnl ---------------------------------------------------------------------------
dnl Should 8/12 bit jpeg mode be enabled?
dnl ---------------------------------------------------------------------------