summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBob Friesenhahn <bfriesen@simple.dallas.tx.us>2011-04-09 15:43:03 +0000
committerBob Friesenhahn <bfriesen@simple.dallas.tx.us>2011-04-09 15:43:03 +0000
commitc546a4ccf89f314d3d2b2bfe77a0870da3d842db (patch)
tree844bf216375977bb7e83c154bf21fdddc2c92f90 /configure.ac
parent519b72700430b84c99db73a832c4c58f3e52ebcd (diff)
downloadlibtiff-git-c546a4ccf89f314d3d2b2bfe77a0870da3d842db.tar.gz
* configure.ac: Should use AC_CANONICAL_HOST since host specifies
the run-time target whereas target is used to specify the final output target if the package is a build tool (like a compiler), which libtiff is not. Resolves libtiff bug 2307 "Use AC_CANONICAL_HOST macro".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 71004707..3313cb9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,8 +30,8 @@ AC_CONFIG_AUX_DIR(config)
AC_CONFIG_MACRO_DIR(m4)
AC_LANG(C)
-dnl Compute the canonical target-system type variable
-AC_CANONICAL_TARGET
+dnl Compute the canonical host (run-time) system type variable
+AC_CANONICAL_HOST
AM_INIT_AUTOMAKE
dnl Do not rebuild generated files every time
@@ -85,7 +85,7 @@ LIBTIFF_VERSION_INFO=$LIBTIFF_CURRENT:$LIBTIFF_REVISION:$LIBTIFF_AGE
# in OpenBSD uses some special semantics for shared libraries. Their soname
# contains only two numbers, major and minor.
# See http://bugzilla.remotesensing.org/show_bug.cgi?id=838 for details.
-#case "$target_os" in
+#case "$host_os" in
# openbsd* | mirbsd*)
# LIBTIFF_VERSION_INFO=$LIBTIFF_MAJOR_VERSION$LIBTIFF_MINOR_VERSION:$LIBTIFF_MICRO_VERSION:0
# ;;
@@ -344,7 +344,7 @@ dnl ---------------------------------------------------------------------------
dnl Check the native cpu bit order.
dnl ---------------------------------------------------------------------------
AC_MSG_CHECKING([native cpu bit order])
-case "$target_cpu" in
+case "$host_cpu" in
i*86*|x86_64*)
HOST_FILLORDER=FILLORDER_LSB2MSB
AC_MSG_RESULT([lsb2msb])