summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLee Howard <faxguy@howardsilvan.com>2010-12-15 00:37:00 +0000
committerLee Howard <faxguy@howardsilvan.com>2010-12-15 00:37:00 +0000
commitccdc78ec32b3cc128e062fddef6b0914640be573 (patch)
tree73127c6d5615347db08d6f2f722f740665a924c0 /configure.ac
parentcb405082bbbe9b293f935f09052d5130ff5c2918 (diff)
downloadlibtiff-git-ccdc78ec32b3cc128e062fddef6b0914640be573.tar.gz
* configure.ac, libtiff/Makefile.am: Build tif_win32.c on
Windows except on Cygwin http://bugzilla.maptools.org/show_bug.cgi?id=2224
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cd892bd9..fd4fcb4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -777,6 +777,25 @@ fi
AM_CONDITIONAL(HAVE_OPENGL, test "$HAVE_OPENGL" = "yes")
dnl ---------------------------------------------------------------------------
+dnl Check for Win32 IO: make sure we have windows.h but not cygwin
+dnl this must be after the ogl test, since that looks for windows.h and we
+dnl test it
+dnl ---------------------------------------------------------------------------
+
+win32_io_ok=no
+case "${host_os}" in
+ cygwin*)
+ ;;
+ *)
+ if test x"$ac_cv_header_windows_h" = xyes; then
+ win32_io_ok=yes
+ AC_DEFINE(USE_WIN32_FILEIO,1,[define to use win32 IO system])
+ fi
+ ;;
+esac
+AM_CONDITIONAL([WIN32_IO], [test "$win32_io_ok" = yes])
+
+dnl ---------------------------------------------------------------------------
dnl Check for X Athena Widgets
dnl ---------------------------------------------------------------------------
@@ -898,6 +917,7 @@ LOC_MSG([ C compiler: ${CC} ${CFLAGS}])
LOC_MSG([ C++ compiler: ${CXX} ${CXXFLAGS}])
LOC_MSG([ Enable runtime linker paths: ${HAVE_RPATH}])
LOC_MSG([ Support Microsoft Document Imaging: ${HAVE_MDI}])
+LOC_MSG([ Use win32 IO: ${win32_io_ok}])
LOC_MSG()
LOC_MSG([ Support for internal codecs:])
LOC_MSG([ CCITT Group 3 & 4 algorithms: ${HAVE_CCITT}])