summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrey Kiselev <dron@ak4719.spb.edu>2007-06-28 13:50:27 +0000
committerAndrey Kiselev <dron@ak4719.spb.edu>2007-06-28 13:50:27 +0000
commitd8207f580b5a0ccadbb449443c6af13978766264 (patch)
tree223135f934c5d441feecc49629889fca448b1bd7 /configure.ac
parent635c6b8cecfb8daa9f6b6cd07e41658cbfcdf6e6 (diff)
downloadlibtiff-git-d8207f580b5a0ccadbb449443c6af13978766264.tar.gz
Version number has been changed; use libtool versioning instead of
package release numbers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac49
1 files changed, 36 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index c6a94e79..0d4e2a50 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,7 +25,7 @@ dnl OF THIS SOFTWARE.
dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([LibTIFF Software], 3.8.2, [tiff@lists.maptools.org], tiff)
+AC_INIT([LibTIFF Software], 4.0.0alpha, [tiff@lists.maptools.org], tiff)
AC_CONFIG_AUX_DIR(config)
AC_CONFIG_MACRO_DIR(m4)
AC_LANG(C)
@@ -39,26 +39,49 @@ AM_MAINTAINER_MODE
dnl Versioning.
dnl Don't fill the ALPHA_VERSION field, if not applicable.
-LIBTIFF_MAJOR_VERSION=3
-LIBTIFF_MINOR_VERSION=8
-LIBTIFF_MICRO_VERSION=2
-LIBTIFF_ALPHA_VERSION=
+LIBTIFF_MAJOR_VERSION=4
+LIBTIFF_MINOR_VERSION=0
+LIBTIFF_MICRO_VERSION=0
+LIBTIFF_ALPHA_VERSION=alpha
LIBTIFF_VERSION=$LIBTIFF_MAJOR_VERSION.$LIBTIFF_MINOR_VERSION.$LIBTIFF_MICRO_VERSION$LIBTIFF_ALPHA_VERSION
dnl This will be used with the 'make release' target
LIBTIFF_RELEASE_DATE=`date +"%Y%m%d"`
+dnl Following version updating rules are quoted from the libtool manual.
+dnl
+dnl - Update the version information only immediately before a public
+dnl release of your software. More frequent updates are unnecessary,
+dnl and only guarantee that the current interface number gets larger
+dnl faster.
+dnl
+dnl - If the library source code has not changed at all since the last
+dnl update, then increment REVISION (`C:R:A' becomes `C:r+1:A').
+dnl
+dnl - If any interfaces have been added, removed, or changed since the
+dnl last update, increment CURRENT, and set REVISION to 0.
+dnl
+dnl - If any interfaces have been added since the last public release,
+dnl then increment AGE.
+dnl
+dnl - If any interfaces have been removed since the last public release,
+dnl then set AGE to 0.
+LIBTIFF_CURRENT=5
+LIBTIFF_REVISION=0
+LIBTIFF_AGE=0
+LIBTIFF_VERSION_INFO=$LIBTIFF_CURRENT:$LIBTIFF_REVISION:$LIBTIFF_AGE
+
# This is a special hack for OpenBSD and MirOS systems. The dynamic linker
# in OpenBSD uses some special semantics for shared libraries. Their soname
# contains only two numbers, major and minor.
# See http://bugzilla.remotesensing.org/show_bug.cgi?id=838 for details.
-case "$target_os" in
- openbsd* | mirbsd*)
- LIBTIFF_VERSION_INFO=$LIBTIFF_MAJOR_VERSION$LIBTIFF_MINOR_VERSION:$LIBTIFF_MICRO_VERSION$LIBTIFF_ALPHA_VERSION:0
- ;;
- *)
- LIBTIFF_VERSION_INFO=$LIBTIFF_MAJOR_VERSION:$LIBTIFF_MINOR_VERSION:$LIBTIFF_MICRO_VERSION$LIBTIFF_ALPHA_VERSION
- ;;
-esac
+#case "$target_os" in
+# openbsd* | mirbsd*)
+# LIBTIFF_VERSION_INFO=$LIBTIFF_MAJOR_VERSION$LIBTIFF_MINOR_VERSION:$LIBTIFF_MICRO_VERSION:0
+# ;;
+# *)
+# LIBTIFF_VERSION_INFO=$LIBTIFF_MAJOR_VERSION:$LIBTIFF_MINOR_VERSION:$LIBTIFF_MICRO_VERSION
+# ;;
+#esac
AC_SUBST(LIBTIFF_MAJOR_VERSION)
AC_SUBST(LIBTIFF_MINOR_VERSION)