summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBob Friesenhahn <bfriesen@simple.dallas.tx.us>2013-03-29 16:50:11 +0000
committerBob Friesenhahn <bfriesen@simple.dallas.tx.us>2013-03-29 16:50:11 +0000
commite90c73e61120c1597cbc9cd9eda55f8166066e3a (patch)
tree00d333f1bb661c05207802f2ea489b5fe68830b0 /configure.ac
parentfeb6bd9f1df6d3f65f17227158ddf278b121f52e (diff)
downloadlibtiff-git-e90c73e61120c1597cbc9cd9eda55f8166066e3a.tar.gz
* configure.ac: Applied patch by Brad Smith to improve pkg-config
static linking by adding -lm to Libs.private when needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e1b8d407..d4be12ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,18 +154,22 @@ LT_LANG([C++])
# Enable support for silent build rules
AM_SILENT_RULES
+tiff_libs_private=
+AC_SUBST(tiff_libs_private)
+
dnl We don't need to add math library to all targets
case "${host_os}" in
cygwin* | mingw32* | beos* | darwin*)
;;
*)
- AC_CHECK_LIB(m,sin,,,)
+ AC_CHECK_LIB(m,sin,[libm_lib=yes], [libm_lib=no],)
+ if test "x$libm_lib" = "xyes" ; then
+ LIBS="-lm $LIBS"
+ tiff_libs_private="-lm ${tiff_libs_private}"
+ fi
;;
esac
-tiff_libs_private=
-AC_SUBST(tiff_libs_private)
-
dnl Checks for header files.
AC_CHECK_HEADERS([assert.h fcntl.h io.h limits.h malloc.h search.h sys/time.h unistd.h])