summaryrefslogtreecommitdiff
path: root/port/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'port/CMakeLists.txt')
-rw-r--r--port/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/port/CMakeLists.txt b/port/CMakeLists.txt
index 354ed4d7..8b221d1d 100644
--- a/port/CMakeLists.txt
+++ b/port/CMakeLists.txt
@@ -39,7 +39,7 @@ endif()
if(NOT HAVE_LFIND)
list(APPEND port_USED_FILES lfind.c)
endif()
-if(NOT HAVE_SNPRINTF AND NOT HAVE__SNPRINTF)
+if(MSVC AND NOT HAVE_SNPRINTF)
list(APPEND port_USED_FILES snprintf.c)
endif()
if(NOT HAVE_STRCASECMP)