summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordron <dron>2006-04-20 12:26:46 +0000
committerdron <dron>2006-04-20 12:26:46 +0000
commit13c52753793ebc6ef2e86f710626fe99581272a7 (patch)
tree547b27d906d391fab9c135e77a1fab0e655676d8 /configure.ac
parent7bbdee3783c193625b66ee6cf06e1172d4ad56b6 (diff)
downloadlibtiff-13c52753793ebc6ef2e86f710626fe99581272a7.tar.gz
Added tests for io.h header and setmode() function.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e5406cda..68713f43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,7 +93,7 @@ case "$target_os" in
esac
dnl Checks for header files.
-AC_CHECK_HEADERS([assert.h fcntl.h limits.h malloc.h search.h sys/time.h unistd.h])
+AC_CHECK_HEADERS([assert.h fcntl.h io.h limits.h malloc.h search.h sys/time.h unistd.h])
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -114,7 +114,7 @@ AC_CHECK_TYPES([int8, int16, int32],,,
])
dnl Checks for library functions.
-AC_CHECK_FUNCS([floor isascii memmove memset mmap pow sqrt strchr strrchr strstr strtol])
+AC_CHECK_FUNCS([floor isascii memmove memset mmap pow setmode sqrt strchr strrchr strstr strtol])
dnl Will use local replacements for unavailable functions
AC_REPLACE_FUNCS(getopt)