summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGary V. Vaughan <gary@gnu.org>2013-10-30 17:39:06 +1300
committerGary V. Vaughan <gary@gnu.org>2014-01-02 12:06:29 +1300
commit747c60634e269ecf740254d86f4a4a2500c20524 (patch)
tree0d221fa562edb94962130c7300550d8b12cafd05 /Makefile.am
parentcc189e7daf95b91d22c585b2cdf6b787c8e3c3c6 (diff)
downloadlibtool-747c60634e269ecf740254d86f4a4a2500c20524.tar.gz
tests: use $GREP throughout.
Trust the user, and use $GREP from TESTS_EVVIRONMENT uniformly. * Makefile.am (TESTS_ENVIRONMENT): Add GREP setting. * tests/am-subdir.at, tests/archive-in-archive.at, tests/bindir.at, tests/configure-iface.at, tests/cwrapper.at, tests/darwin.at, tests/demo.at, tests/destdir.at, tests/dumpbin-symbols.at, tests/early-libtool.at, tests/execute-mode.at, tests/export-def.at, tests/export.at, tests/f77demo.at, tests/fcdemo.at, tests/flags.at, tests/help.at, tests/inherited_flags.at, tests/install.at, tests/lalib-syntax.at, tests/libtool.at, tests/libtoolize.at, tests/localization.at, tests/lt_dladvise.at, tests/lt_dlopen.at, tests/lt_dlopenext.at, tests/ltdl-api.at, tests/ltdl-libdir.at, tests/mdemo.at, tests/old-m4-iface.at, tests/pic_flag.at, tests/resident.at, tests/runpath-in-lalib.at, tests/search-path.at, tests/static.at, tests/sysroot.at, tests/template.at, tests/testsuite.at, tests/versioning.at: Replace all hardcoded grep invocations with $GREP. Signed-off-by: Gary V. Vaughan <gary@gnu.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6ccc4d0e..c59fe304 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -691,7 +691,7 @@ TESTS_ENVIRONMENT = MAKE="$(MAKE)" CC="$(CC)" CFLAGS="$(CFLAGS)" \
CPP="$(CPP)" CPPFLAGS="$(CPPFLAGS)" LD="$(LD)" LDFLAGS="$(LDFLAGS)" \
LIBS="$(LIBS)" LN_S="$(LN_S)" NM="$(NM)" RANLIB="$(RANLIB)" \
AR="$(AR)" \
- SED="$(SED)" STRIP="$(STRIP)" lt_INSTALL="$(INSTALL)" \
+ GREP="$(GREP)" SED="$(SED)" STRIP="$(STRIP)" lt_INSTALL="$(INSTALL)" \
MANIFEST_TOOL="$(MANIFEST_TOOL)" \
OBJEXT="$(OBJEXT)" EXEEXT="$(EXEEXT)" \
SHELL="$(SHELL)" CONFIG_SHELL="$(SHELL)" \