summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary V. Vaughan <gary@gnu.org>2011-11-16 18:59:01 +0700
committerGary V. Vaughan <gary@gnu.org>2011-11-25 14:53:41 +0700
commit06c6555d4a77a5e91f43da3451586534da93e0ae (patch)
treed7231883b36c9cc1afa28ea9a738f54afe36c8ff /configure.ac
parent59e09030ae0f79108745dd527b2fd03f0f149696 (diff)
downloadlibtool-06c6555d4a77a5e91f43da3451586534da93e0ae.tar.gz
syntax-check: fix violations and implement sc_useless_quotes_in_assignment.
Contrary to popular belief, Bourne shell does not resplit RHS of assignments after expansion, so if there are no unquoted shell metacharacters or whitespace, the quotes are useless. * cfg.mk (_sc_search_regexp_or_exclude): A variation of gnulib's _sc_search_regexp that also allows individual exclusions at the site of what would otherwise match by adding a comment. (sc_useless_quotes_in_assignment): New syntax-check rule to ensure we don't reintroduce useless quoted assignments. * bootstrap, bootstrap.conf, build-aux/edit-readme-alpha, build-aux/general.m4sh, build-aux/getopt.m4sh, build-aux/ltmain.m4sh, build-aux/options-parser, configure.ac, doc/libtool.texi, libtoolize.m4sh, m4/libtool.m4, m4/ltdl.m4, m4/ltoptions.m4, tests/cwrapper.at, tests/defs.m4sh, tests/lalib-syntax.at, tests/libtoolize.at, tests/lt_dlopenext.at, tests/mdemo/configure.ac, tests/mdemo2/configure.ac, tests/need_lib_prefix.at, tests/no-executables.at, tests/quote.test, tests/suffix.test: Remove spurious quotes. Signed-off-by: Gary V. Vaughan <gary@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5c07723f..39d06f47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,7 +94,7 @@ AM_SILENT_RULES([yes])
# You can set autobuild_mode at configure time to specify a "unique"
# string for this build.
: ${autobuild_mode=default}
-AB_VERSION="AC_PACKAGE_VERSION"
+AB_VERSION='AC_PACKAGE_VERSION'
AB_INIT([$autobuild_mode])