summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary V. Vaughan <gary@gnu.org>2011-11-06 11:48:38 +0700
committerGary V. Vaughan <gary@gnu.org>2011-11-08 20:07:29 +0700
commit0ecdf9b9edd1524061fe2267a513c33b75b84969 (patch)
tree1d45e7596e47ae8b19983c0b8e319bc51f029181 /configure.ac
parentb7b68a3ce0e185d344d3cb0767867f1da5a6d4fb (diff)
downloadlibtool-0ecdf9b9edd1524061fe2267a513c33b75b84969.tar.gz
maint: substitute static directory names.
By substituting just the directory name as passed to the macro, aux_dir can be used with or without $srcdir prefix, which is more flexible, and always means the same thing in each file, rather than sometimes being a directory name, sometimes relative to $top_srcdir. * configure.ac (AC_CONFIG_AUX_DIR, AC_CONFIG_MACRO_DIR) (LT_CONFIG_LTDL_DIR): Don't force config.status substitutions with unexpanded shell variables. * Makefile.am, tests/defs.m4sh: Adjust. Signed-off-by: Gary V. Vaughan <gary@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f3be9523..097361b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,11 +42,11 @@ m4_ifndef([AC_PACKAGE_URL],
# them in two places making renames error prone, and where copies
# might get out of sync.
m4_define([AC_CONFIG_AUX_DIR],
- m4_defn([AC_CONFIG_AUX_DIR])[AC_SUBST([aux_dir], ['${srcdir}/$1'])])
+ m4_defn([AC_CONFIG_AUX_DIR])[AC_SUBST([aux_dir], [$1])])
m4_define([LT_CONFIG_LTDL_DIR],
- m4_defn([LT_CONFIG_LTDL_DIR])[AC_SUBST([ltdl_dir], ['${srcdir}/$1'])])
+ m4_defn([LT_CONFIG_LTDL_DIR])[AC_SUBST([ltdl_dir], [$1])])
m4_define([AC_CONFIG_MACRO_DIR],
- m4_defn([AC_CONFIG_MACRO_DIR])[AC_SUBST([macro_dir], ['${srcdir}/$1'])])
+ m4_defn([AC_CONFIG_MACRO_DIR])[AC_SUBST([macro_dir], [$1])])
AC_CONFIG_HEADERS([config.h:config-h.in])
AC_CONFIG_SRCDIR([libtoolize.m4sh])