summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary V. Vaughan <gary@gnu.org>2011-11-27 23:50:15 +0700
committerGary V. Vaughan <gary@gnu.org>2012-10-04 20:11:06 +0700
commit2c387b8e10eeb3a51a769de439406f20cad365fd (patch)
tree84e82935e668d3cb0380612dc4108316dbcaa052 /configure.ac
parent0024c50ba355e23dd1ef2e95ded517ed6cdbf36d (diff)
downloadlibtool-2c387b8e10eeb3a51a769de439406f20cad365fd.tar.gz
configure: remove unused conditionals and support for order only rules.
Clean up some more unused cruft. * configure.ac (HAVE_CXX, HAVE_F77, HAVE_FC, HAVE_GCJ, HAVE_RC): Remove. These were only used by the recently removed legacy tests. [order-only prerequisites]: Ditto. Signed-off-by: Gary V. Vaughan <gary@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 0 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index f3a5e730..ae8dc2d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,44 +157,6 @@ LT_LANG(Windows Resource)
AC_SUBST([to_host_file_cmd])dnl
AC_SUBST([to_tool_file_cmd])dnl
-## --------------------------- ##
-## Work out which tests to run ##
-## --------------------------- ##
-AM_CONDITIONAL(HAVE_CXX,[test -n "[$]_LT_TAGVAR(compiler, CXX)"])
-AM_CONDITIONAL(HAVE_F77,[test -n "[$]_LT_TAGVAR(compiler, F77)"])
-AM_CONDITIONAL(HAVE_FC,[test -n "[$]_LT_TAGVAR(compiler, FC)"])
-AM_CONDITIONAL(HAVE_GCJ, [test -n "[$]_LT_TAGVAR(compiler, GCJ)"])
-AM_CONDITIONAL(HAVE_RC, [test -n "[$]_LT_TAGVAR(compiler, RC)"])
-
-## Whether `make' supports order-only prerequisites.
-AC_CACHE_CHECK([whether ${MAKE-make} supports order-only prerequisites],
- [lt_cv_make_order_only],
- [mkdir conftest.dir
- cd conftest.dir
- touch b
- touch a
-cat >confmk << 'END'
-ORDER = |
-a: b $(ORDER) c
-a b c:
- touch $[]@
-END
- touch c
- if ${MAKE-make} -s -q -f confmk >/dev/null 2>&1; then
- lt_cv_make_order_only=yes
- else
- lt_cv_make_order_only=no
- fi
- cd ..
- rm -rf conftest.dir
-])
-if test yes = "$lt_cv_make_order_only"; then
- ORDER='|'
-else
- ORDER=''
-fi
-AC_SUBST([ORDER])
-
## ---------------------- ##
## Gnulib initialisation. ##
## ---------------------- ##