summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary V. Vaughan <gary@gnu.org>2011-10-20 22:17:23 +0700
committerGary V. Vaughan <gary@gnu.org>2011-10-27 10:22:44 +0700
commit4008119bcc321096bde69d3e81a4d6af76e5c7b9 (patch)
tree3f506f4a9ef7c3057110e71208b41cb8f6a2f644 /configure.ac
parenta7d34118b2e87f724b4801db8cf0ed5e9b13fc79 (diff)
downloadlibtool-4008119bcc321096bde69d3e81a4d6af76e5c7b9.tar.gz
maint: use gnulib's git-version-gen instead of mkstamp.
* libltdl/config/mkstamp: File removed. * bootstrap.conf (gnulib_modules): Add git-version-gen. * configure.ac (AC_INIT, package_revision): Use git-version-gen to calculate version number. (TIMESTAMP): Removed. * libtoolize.m4sh, libltdl/config/ltmain.m4sh, libltdl/m4/libtool.m4 (TIMESTAMP): Ditto. * Makefile.am (TIMESTAMP): Ditto. (MKSTAMP): Renamed from this... (git_version_gen): ...to this. Set revision here. An alpha is now a release with an odd micro relase number. (rebuild): Don't reset revision here. (build_scripts): Remove mkstamp, add git-version-gen. (EXTRA_DIST, BUILT_SOURCES): Add .version. (libltdl/config/ltmain.sh, libltdl/m4/ltversion.m4, tests/package.m4): Don't depend on configure.ac or ChangeLog to determine when the version number has reved, use .version directly. (.version): Flush most recent configure calculated VERSION to disk. (dist-hook): Flush current VERSION to disk at dist time. (dotserial): Distributed file to cache the serial number for when git is not available to recalculate it when building from a release tarball. (dist-hook): Make sure .serial is created. (libltdl/config/ltversion.m4): Use .serial when it is present (in a dist tarball) or calculate with git otherwise (in a git working directory). (EXTRA_DIST): Add .serial file. Signed-off-by: Gary V. Vaughan <gary@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 9 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index c51ec287..b2aff61a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,9 +31,11 @@ dnl Oldest automake required for bootstrap is below in AM_INIT_AUTOMAKE.
## ------------------------ ##
## Autoconf initialisation. ##
## ------------------------ ##
-AC_INIT([GNU Libtool], [2.4.3a], [bug-libtool@gnu.org])
+AC_INIT([GNU Libtool],
+ m4_esyscmd([libltdl/config/git-version-gen .tarball-version]),
+ [bug-libtool@gnu.org])
m4_ifndef([AC_PACKAGE_URL],
- [AC_SUBST([PACKAGE_URL], [http://www.gnu.org/software/libtool/])])
+ [AC_SUBST([PACKAGE_URL], [http://www.gnu.org/s/libtool/])])
# Since we already declare these directories in this file, save those
# choices, and push the results into Makefile.am to avoid declaring
@@ -53,6 +55,8 @@ AC_CONFIG_AUX_DIR([libltdl/config])
AC_CONFIG_MACRO_DIR([libltdl/m4])
AC_CONFIG_LIBOBJ_DIR([libltdl])
+package_revision=`$SHELL $ac_aux_dir/git-version-gen .tarball-version`
+AC_SUBST([package_revision])
## ------------------------ ##
## Autotest initialisation. ##
@@ -68,20 +72,8 @@ AC_SUBST([AUTOTEST], ['$(AUTOM4TE) --language=autotest'])
## ---------------------------------------- ##
# This is a sanity check so we can see which version is used in bug reports.
-# It is assumed that we only want to see the date extension for cvs libtool
-# versions (i.e. "odd" letters) and not actual alpha releases.
-TIMESTAMP=`${CONFIG_SHELL} ${ac_aux_dir}/mkstamp ${srcdir}`
-package_revision=`( set $TIMESTAMP; echo $1; )`
-case $package_revision in
- *[[bdfhjlnprtvxz]])
- TIMESTAMP=
- ;;
-esac
-timestamp_string="${TIMESTAMP:+ (Build:$TIMESTAMP)}"
-AS_BOX([Configuring AC_PACKAGE_TARNAME$timestamp_string AC_PACKAGE_VERSION])
+AS_BOX([Configuring AC_PACKAGE_TARNAME AC_PACKAGE_VERSION])
echo
-AC_SUBST([TIMESTAMP])
-AC_SUBST([package_revision])
## ------------------------ ##
@@ -101,7 +93,7 @@ AM_INIT_AUTOMAKE([1.11.1 gnu subdir-objects dist-xz color-tests parallel-tests])
# You can set autobuild_mode at configure time to specify a "unique"
# string for this build.
: ${autobuild_mode=default}
-AB_VERSION="AC_PACKAGE_VERSION ($TIMESTAMP)"
+AB_VERSION="AC_PACKAGE_VERSION"
AB_INIT([$autobuild_mode])
@@ -109,7 +101,7 @@ dnl We use m4sh to generate libtool's portable shell scripts
AC_SUBST([M4SH], ['$(AUTOM4TE) --language=m4sh'])
dnl Make sure config.status is regenerated when the version timestamp changes
-AC_SUBST([CONFIG_STATUS_DEPENDENCIES], ['$(top_srcdir)/ChangeLog'])
+AC_SUBST([CONFIG_STATUS_DEPENDENCIES], ['$(srcdir)/.version'])
## ------------------------------- ##