summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary V. Vaughan <gary@gnu.org>2011-11-20 21:08:24 +0700
committerGary V. Vaughan <gary@gnu.org>2011-11-25 14:53:42 +0700
commit8fad6be03e8eca44e5e771cfbb907d3840a8e01e (patch)
tree82ccc492a8aef1fef65fdaecca176331e43aa5a0 /configure.ac
parent4757bf0637658fd2e298042d9f7a0d51c5f49495 (diff)
downloadlibtool-8fad6be03e8eca44e5e771cfbb907d3840a8e01e.tar.gz
syntax-check: fix violations and implement sc_useless_braces_in_variable_derefs.
Until now, libtool sources have used braced variable names seemingly at random! Almost always the braces are just noise, so remove all the unnecessary ones. * cfg.mk (sc_useless_braces_in_variable_derefs): New syntax check rule to ensure we only reintroduce braced variable dereferences if they are followed by a valid variable name character. build-aux/general.m4sh, build-aux/git-hooks/commit-msg, build-aux/ltmain.m4sh, build-aux/options-parser, configure.ac, libltdl/configure.ac, m4/libtool.m4, m4/ltdl.m4, m4/ltoptions.m4, tests/defs.m4sh, tests/demo-nopic.test, tests/depdemo/configure.ac, tests/flags.at, tests/link.test, tests/objectlist.test, tests/quote.test, tests/static.at: Remove spurious braces. Signed-off-by: Gary V. Vaughan <gary@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5fe1cb84..3e32c641 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,8 +109,8 @@ AC_SUBST([CONFIG_STATUS_DEPENDENCIES], ['$(srcdir)/.version'])
## Libtool specific configuration. ##
## ------------------------------- ##
-AC_SUBST([aclocaldir], ["\${datadir}/aclocal"])
-AC_SUBST([pkgdatadir], ["\${datadir}/$PACKAGE"])
+AC_SUBST([aclocaldir], ["\$(datadir)/aclocal"])
+AC_SUBST([pkgdatadir], ["\$(datadir)/$PACKAGE"])
AC_ARG_ENABLE(ltdl-install,
[AS_HELP_STRING([--disable-ltdl-install], [do not install libltdl])])
@@ -132,7 +132,7 @@ AC_SUBST([CONF_SUBDIRS])
DIST_MAKEFILE_LIST=
for dir in $CONF_SUBDIRS; do
- DIST_MAKEFILE_LIST="${DIST_MAKEFILE_LIST}$dir/Makefile "
+ DIST_MAKEFILE_LIST="$DIST_MAKEFILE_LIST$dir/Makefile "
done
AC_SUBST([DIST_MAKEFILE_LIST])