summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2010-08-22 20:33:49 +0200
committerRalf Wildenhues <Ralf.Wildenhues@gmx.de>2010-08-22 20:35:06 +0200
commit92d24b3d80c5506db3ff2a2fd0165ac1b96d2bb3 (patch)
treed8cf5df0c00459b06589c36f99f1cb5ee65134cd /configure.ac
parent3160ead1712bbe567d30defd2a65cfe03f34406d (diff)
downloadlibtool-92d24b3d80c5506db3ff2a2fd0165ac1b96d2bb3.tar.gz
configure: use Autobuild AB_INIT if available.
* configure.ac: Call AB_INIT if it is defined, with $autobuild_mode as argument, to be set at configure time. Set AB_VERSION to the Libtool version string. * HACKING: Update. * libltdl/m4/.gitignore: Ignore autobuild.m4. Signed-off-by: Ralf Wildenhues <Ralf.Wildenhues@gmx.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 35c79f1e..9690a056 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,6 +127,19 @@ dnl These are bootstrap requirements! Once built, libtool may work with
dnl much older releases of autoconf and automake. See release notes.
AM_INIT_AUTOMAKE([1.10.1 gnu subdir-objects dist-lzma])
+
+## ------------------------- ##
+## Autobuild initialisation. ##
+## ------------------------- ##
+
+# You can set autobuild_mode at configure time to specify a "unique"
+# string for this build.
+: ${autobuild_mode=default}
+AB_VERSION="AC_PACKAGE_VERSION ($TIMESTAMP)"
+m4_ifdef([AB_INIT],
+ [AB_INIT([$autobuild_mode])])
+
+
dnl We use m4sh to generate libtool's portable shell scripts
AC_SUBST([M4SH], ['$(AUTOM4TE) --language=m4sh'])