summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2005-08-08 09:23:57 +0000
committerRalf Wildenhues <Ralf.Wildenhues@gmx.de>2005-08-08 09:23:57 +0000
commita1b595f6abbd3ed4923cbcd7cab1dc08ecfaf2ac (patch)
treeee737fa249852c350e47d3f2d2b76dbe37c81ac6 /configure.ac
parent6d1b0beae3729c35d125dbd22bfb893ba04fa39f (diff)
downloadlibtool-a1b595f6abbd3ed4923cbcd7cab1dc08ecfaf2ac.tar.gz
* m4/libtool.m4 (_LT_PROG_FC, _LT_LANG_FC_CONFIG): New macros
for modern Fortran. (LT_LANG, _LT_LANG_DEFAULT_CONFIG, _LT_SYS_DYNAMIC_LINKER, _LT_SYS_HIDDEN_LIBDEPS): Adjusted. * tests/fcdemo-conf.test, tests/fcdemo-exec.test, tests/fcdemo-make.test, tests/fcdemo-shared.test, tests/fcdemo-static.test, tests/fcdemo/Makefile.am, tests/fcdemo/README, tests/fcdemo/configure.ac, tests/fcdemo/cprogram.c, tests/fcdemo/foo.h, tests/fcdemo/fooc.c, tests/fcdemo/foof.f90, tests/fcdemo/foof2.f90, tests/fcdemo/foof3.f90, tests/fcdemo/fprogram.f90: New tests for Fortran. * tests/convenience.at: Extended. * Makefile.am, configure.ac: Adjusted. * NEWS: Updated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9d58a772..8dfc19c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,8 +136,8 @@ fi
# All subdirectories that are configured on demand, but that must be
# included in the distribution.
-CONF_SUBDIRS="tests/cdemo tests/demo tests/depdemo tests/f77demo tests/mdemo \
- tests/mdemo2 tests/pdemo tests/tagdemo"
+CONF_SUBDIRS="tests/cdemo tests/demo tests/depdemo tests/f77demo tests/fcdemo \
+ tests/mdemo tests/mdemo2 tests/pdemo tests/tagdemo"
AC_SUBST([CONF_SUBDIRS])
DIST_MAKEFILE_LIST=
@@ -166,6 +166,7 @@ LTDL_INIT
# Enable all the language support we can
LT_LANG(C++)
LT_LANG(Fortran 77)
+LT_LANG(Fortran)
LT_LANG(Java)
LT_LANG(Windows Resource)
@@ -175,6 +176,7 @@ LT_LANG(Windows Resource)
## --------------------------- ##
AM_CONDITIONAL(HAVE_CXX,[test -n "[$]_LT_TAGVAR(compiler, CXX)"])
AM_CONDITIONAL(HAVE_F77,[test -n "[$]_LT_TAGVAR(compiler, F77)"])
+AM_CONDITIONAL(HAVE_FC,[test -n "[$]_LT_TAGVAR(compiler, FC)"])
AM_CONDITIONAL(HAVE_GCJ, [test -n "[$]_LT_TAGVAR(compiler, GCJ)"])
AM_CONDITIONAL(HAVE_RC, [test -n "[$]_LT_TAGVAR(compiler, RC)"])