summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary V. Vaughan <gary@gnu.org>2008-09-07 05:12:18 +0800
committerGary V. Vaughan <gary@gnu.org>2008-09-07 05:12:18 +0800
commitc2b86363045da50958294cfc17095cc44021f163 (patch)
tree967a0a889648a157dc8868b000061285c3223358 /configure.ac
parentc2bdda82d31be40508c15630f73816f5e97659d0 (diff)
downloadlibtool-c2b86363045da50958294cfc17095cc44021f163.tar.gz
Prepare for next stable release.
* libltdl/Makefile.inc (LTDL_VERSION_INFO): Update. * libltdl/m4/libtool.m4: Bump serial number to account for changes since 2.2.4 release. * INSTALL, config/config.guess, config/texinfo.tex: Updated from canonical source. * configure.ac (AM_INIT_AUTOMAKE): Specify dist-lzma, which was introduced after automake-1.10 was released. (abs_top_srcdir, abs_top_builddir): No need to substitute these from configure anymore, since we require automake 1.10.1, which does perform the substitutions properly. (TIMESTAMP): Normal releases were displaying the long-form timestamp. Fix to show the short release timestamp as per alpha release numbers. * NEWS: Update with missing entries from ChangeLog. * HACKING (Release Procedure): We release lzma tarballs now but no xdeltas. * Makefile.maint: Updated to match Release Procedure instructions in HACKING. Signed-off-by: Gary V. Vaughan <gary@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 9c181db7..9cf7131a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,7 +30,7 @@ dnl Oldest automake required for bootstrap is below in AM_INIT_AUTOMAKE.
## ------------------------ ##
## Autoconf initialisation. ##
## ------------------------ ##
-AC_INIT([libtool], [2.2.5a], [bug-libtool@gnu.org])
+AC_INIT([libtool], [2.2.6], [bug-libtool@gnu.org])
AC_CONFIG_HEADERS([config.h:config-h.in])
AC_CONFIG_SRCDIR([libtoolize.in])
LT_CONFIG_LTDL_DIR([libltdl], [nonrecursive])
@@ -106,7 +106,7 @@ AC_SUBST([LASTRELEASE])
TIMESTAMP=`${CONFIG_SHELL} ${ac_aux_dir}/mkstamp ${srcdir}`
package_revision=`( set $TIMESTAMP; echo $1; )`
case $lt_alpha in
- [[bdfhjlnprtvxz]])
+ ""|[[bdfhjlnprtvxz]])
TIMESTAMP=
;;
esac
@@ -120,9 +120,9 @@ AC_SUBST([package_revision])
## Automake Initialisation. ##
## ------------------------ ##
-dnl These are bootstrap requirements, once built, libtool may work with
+dnl These are bootstrap requirements! Once built, libtool may work with
dnl much older releases of autoconf and automake. See release notes.
-AM_INIT_AUTOMAKE([1.9 gnu subdir-objects dist-bzip2])
+AM_INIT_AUTOMAKE([1.10.1 gnu subdir-objects dist-lzma])
dnl We use m4sh to generate libtool's portable shell scripts
AC_SUBST([M4SH], ['$(AUTOM4TE) --language=m4sh'])
@@ -130,7 +130,8 @@ AC_SUBST([M4SH], ['$(AUTOM4TE) --language=m4sh'])
dnl Make sure config.status is regenerated when the version timestamp changes
AC_SUBST([CONFIG_STATUS_DEPENDENCIES], ['$(top_srcdir)/ChangeLog'])
-dnl automake-1.9.x or autoconf-2.59 don't support subdir libobjs
+dnl when installed libtool is used with automake-1.9.x or autoconf-2.59,
+dnl subdir libobjs don't work without a little extra help
AC_MSG_CHECKING([whether subdir libobjs are useable])
test -f $srcdir/argz.c || sublibobjs_supported=yes
AM_CONDITIONAL([LTDL_SUBDIR_LIBOBJS], test x"${sublibobjs_supported-no}" != xno)
@@ -141,9 +142,6 @@ AC_MSG_RESULT([${sublibobjs_supported-no}])
## Libtool specific configuration. ##
## ------------------------------- ##
-dnl automake-1.9 does not substitute these two by default
-AC_SUBST([abs_top_srcdir])
-AC_SUBST([abs_top_builddir])
AC_SUBST([aclocaldir], ["\${datadir}/aclocal"])
AC_SUBST([pkgdatadir], ["\${datadir}/$PACKAGE"])