summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2010-08-27 07:31:49 +0200
committerRalf Wildenhues <Ralf.Wildenhues@gmx.de>2010-08-27 07:32:22 +0200
commitd1b98fd5399457b8d83daedb3eb4174d42480240 (patch)
tree2dcd580c081f33b85c1359e5f9b35f15b0fc28b9 /configure.ac
parentf8640925f846162590d494e36406e1e04a4f48e8 (diff)
parentb92d7e795871f8d22a13107b92427ae02bf32146 (diff)
downloadlibtool-d1b98fd5399457b8d83daedb3eb4174d42480240.tar.gz
Merge branch 'parallel-tests'
* parallel-tests: check-interactive and check-noninteractive for both testsuites. Adjust docs for renaming and for parallel-tests. Update VERBOSE handling for parallel-tests driver. Enable parallel-tests test driver for the old testsuite. New alias scripts for old tests run more than once. Require Automake 1.11.1 for Libtool, enable color-tests.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 30 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 9690a056..1a0db917 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,7 +125,8 @@ AC_SUBST([package_revision])
dnl These are bootstrap requirements! Once built, libtool may work with
dnl much older releases of autoconf and automake. See release notes.
-AM_INIT_AUTOMAKE([1.10.1 gnu subdir-objects dist-lzma])
+dnl 1.11 is needed for color-tests, 1.11.1 fixes a security issue.
+AM_INIT_AUTOMAKE([1.11.1 gnu subdir-objects dist-lzma color-tests parallel-tests])
## ------------------------- ##
@@ -146,13 +147,6 @@ AC_SUBST([M4SH], ['$(AUTOM4TE) --language=m4sh'])
dnl Make sure config.status is regenerated when the version timestamp changes
AC_SUBST([CONFIG_STATUS_DEPENDENCIES], ['$(top_srcdir)/ChangeLog'])
-dnl when installed libtool is used with automake-1.9.x or autoconf-2.59,
-dnl subdir libobjs don't work without a little extra help
-AC_MSG_CHECKING([whether subdir libobjs are useable])
-test -f $srcdir/argz.c || sublibobjs_supported=yes
-AM_CONDITIONAL([LTDL_SUBDIR_LIBOBJS], test x"${sublibobjs_supported-no}" != xno)
-AC_MSG_RESULT([${sublibobjs_supported-no}])
-
## ------------------------------- ##
## Libtool specific configuration. ##
@@ -215,6 +209,34 @@ AM_CONDITIONAL(HAVE_FC,[test -n "[$]_LT_TAGVAR(compiler, FC)"])
AM_CONDITIONAL(HAVE_GCJ, [test -n "[$]_LT_TAGVAR(compiler, GCJ)"])
AM_CONDITIONAL(HAVE_RC, [test -n "[$]_LT_TAGVAR(compiler, RC)"])
+## Whether `make' supports order-only prerequisites.
+AC_CACHE_CHECK([whether ${MAKE-make} supports order-only prerequisites],
+ [lt_cv_make_order_only],
+ [mkdir conftest.dir
+ cd conftest.dir
+ touch b
+ touch a
+cat >confmk << 'END'
+a: b | c
+a b c:
+ touch $[]@
+END
+ touch c
+ if ${MAKE-make} -s -q -f confmk 2>/dev/null; then
+ lt_cv_make_order_only=yes
+ else
+ lt_cv_make_order_only=no
+ fi
+ cd ..
+ rm -rf conftest.dir
+])
+if test $lt_cv_make_order_only = yes; then
+ ORDER='|'
+else
+ ORDER=''
+fi
+AC_SUBST([ORDER])
+
## ------------- ##
## Documentation ##
## ------------- ##