summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary V. Vaughan <gary@gnu.org>2005-04-30 09:30:14 +0000
committerGary V. Vaughan <gary@gnu.org>2005-04-30 09:30:14 +0000
commitef4442da9be6915b80547151bf171280a62641e5 (patch)
tree5a272b56ecf7aab0ee0c66cf14d2b26b8f7c3e7d /configure.ac
parentf20477da8e64c784e4c3c06c9a7f2eccd7f24527 (diff)
downloadlibtool-ef4442da9be6915b80547151bf171280a62641e5.tar.gz
Revert the parallel installation changes from November last year:
* libtoolize.m4sh (pkgdatadir, aclocaldir): Substituted from configure. (func_copy_all_from_path): Removed. No longer used. (func_copy_some_files): Simplify now that nothing is copied from a list of possible directories now. (func_scan_files): Remove directory readability check... (func_nonemptydir_p): ...in favour of a dedicated sanity check function called from the main body. (_lt_pkgvdatadir): Set pkgdatadir and aclocaldir appropriately if this is in the environment. * configure.ac: Tests for `ln' removed. (APIVERSION): Removed. * Makefile.am (pkgvdatadir, nobase_dist_pkgvdata_DATA) (nobase_pkgvdata_DATA): Renamed to... (pkgdatadir, nobase_dist_pkgdata_DATA, aclocalfiles): ...these respectively. (edit): Adjust for new variable names. (install-data-local): Don't bother to remove old macro files that will be overwritten by the installation, and perform a manual installation of $(aclocalfiles) to preserve timestamps. (install-exec-hook): Removed. No need to make versioned links. (uninstall-hook): No need to remove versioned links, but now we need to manually remove the manually installed $(aclocalfiles). * doc/libtool.texi: Remove bogus notes about setting ACLOCAL_AMFLAGS for versioned libtool installations. * NEWS: Remove parallel installation item.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 2 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index 0de091d1..9d58a772 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,17 +125,8 @@ AC_SUBST([CONFIG_STATUS_DEPENDENCIES], ['$(top_srcdir)/stamp-vcl'])
## Libtool specific configuration. ##
## ------------------------------- ##
-# The API version is the base version. We must guarantee
-# compatibility for all releases with the same API version.
-# Our current rule is that:
-# * All releases, including the prereleases, in an X.Y series
-# are compatible. So 2.0.1c is compatible with 2.0.
-# * Prereleases on the trunk are all incompatible -- 2.1b and 2.1c
-# aren't the same.
-APIVERSION=`echo "$VERSION" | sed -e 's/^\([[0-9]]*\.[[0-9]]*[[a-z]]*\).*$/\1/'`
-AC_SUBST([APIVERSION])
-AC_SUBST([aclocaldir], ["\${datadir}/aclocal"])
-AC_SUBST([pkgvdatadir], ["\${datadir}/$PACKAGE-$APIVERSION"])
+AC_SUBST([aclocaldir], ["\${datadir}/aclocal"])
+AC_SUBST([pkgdatadir], ["\${datadir}/$PACKAGE"])
AC_ARG_ENABLE(ltdl-install,
[AS_HELP_STRING([--disable-ltdl-install], [do not install libltdl])])
@@ -156,23 +147,6 @@ done
AC_SUBST([DIST_MAKEFILE_LIST])
-# Test for ln. We need use it to install the versioned binaries.
-AC_MSG_CHECKING([whether ln works])
-AC_CACHE_VAL([am_cv_prog_ln], [
-rm -f conftest conftest.file
-: >conftest.file
-if ln conftest.file conftest 2>/dev/null; then
- am_cv_prog_ln=ln
-else
- am_cv_prog_ln='cp -p'
-fi
-rm -f conftest conftest.file])
-AC_SUBST([LN], [$am_cv_prog_ln])
-result=no
-test "x$am_cv_prog_ln" = xln && result=yes
-AC_MSG_RESULT([$result])
-
-
## ---------------- ##
## compiler checks. ##
## ---------------- ##