summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary V. Vaughan <gary@gnu.org>2011-10-24 18:03:23 +0700
committerGary V. Vaughan <gary@gnu.org>2011-11-17 19:20:25 +0700
commitf7f2fac6b265a31d4ba498644a8ce3104ed68fde (patch)
tree0b65e45afbb938aacf9a11cac0ee956f0bb9592a /configure.ac
parent0574d54b16271d2c849006f3b2a2eaae98c4e2ad (diff)
downloadlibtool-f7f2fac6b265a31d4ba498644a8ce3104ed68fde.tar.gz
syntax-check: fix violations and re-enable sc_makefile_at_at_check.
At some point we were supporting some undetermined `broken make', as evidenced by having carried the following code since 2003: ## use @LIBLTDL@ because some broken makes do not accept ## macros in targets, we can only do this because our LIBLTDL ## does not contain $(top_builddir). @LIBLTDL@: $(top_distdir)/libtool \ ... However, we've also had *many* cases of macros in targets for just as long, so most likely we never fully supported makes allegedly broken in this way. As of this release, we explicitly no longer support make implementations that do not accept macros in targets. * cfg.mk (local-checks-to-fix): Remove sc_makefile_at_at_check from list of disabled checks. * configure.ac (order-only prerequisites): Test with the order-only pipe symbol in a macro. * Makefile.am, tests/mdemo/Makefile.am: Convert all @FOO@ to $(FOO). Signed-off-by: Gary V. Vaughan <gary@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7783e07b..5c07723f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,7 +186,8 @@ AC_CACHE_CHECK([whether ${MAKE-make} supports order-only prerequisites],
touch b
touch a
cat >confmk << 'END'
-a: b | c
+ORDER = |
+a: b $(ORDER) c
a b c:
touch $[]@
END