summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAaron Robinson <arobins@microsoft.com>2022-03-05 06:46:40 -0800
committerDave Watson <dade.watson@gmail.com>2022-05-22 10:58:11 -0700
commita8725b058a26e1b37fd83d288fea3a918c3b4a58 (patch)
treebe4b4a160d9ad24a6d85237b838351ccb0d81207 /CMakeLists.txt
parent8584d6fd661d25b75697e4024c79f791848179ce (diff)
downloadlibunwind-a8725b058a26e1b37fd83d288fea3a918c3b4a58.tar.gz
Update based on MSVC static analyzer
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8b542f24..c9d3a666 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,7 +56,6 @@ if ("${CMAKE_GENERATOR}" MATCHES "^Visual Studio.*$")
add_compile_options(-wd4068) # ignore unknown pragma warnings (gcc pragmas)
add_compile_options(-wd4146) # minus operator applied to unsigned
add_compile_options(-wd4244) # possible loss of data
- add_compile_options(-wd4267) # possible loss of data
add_compile_options(-wd4334) # 32-bit shift implicitly converted to 64 bits
# Disable warning due to incorrect format specifier in debugging printf via the Debug macro
@@ -87,7 +86,7 @@ if ("${CMAKE_GENERATOR}" MATCHES "^Visual Studio.*$")
if (NOT HAVE_STDATOMIC_H)
configure_file(include/win/fakestdatomic.h.in ${CMAKE_CURRENT_BINARY_DIR}/include/stdatomic.h)
endif (NOT HAVE_STDATOMIC_H)
-
+
# MSVC compiler is currently missing C11 _Thread_local
check_c_source_compiles("void main() { _Thread_local int a; }" HAVE_THREAD_LOCAL)
if (NOT HAVE_THREAD_LOCAL)