summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdeel Mujahid <3840695+am11@users.noreply.github.com>2022-06-29 02:43:45 +0300
committerGitHub <noreply@github.com>2022-06-28 19:43:45 -0400
commitcfcf3d193a4425f58ed9556ec54b6d7ab0557330 (patch)
tree04da0e1e3fe3dc3fbdb55f53b0fabbf01e033d82 /CMakeLists.txt
parent9c7245b97d515c9bdb9f8b63dc1d4e35e2fafa56 (diff)
downloadlibunwind-cfcf3d193a4425f58ed9556ec54b6d7ab0557330.tar.gz
Add remote unwinding support for macOS (#365)
* Add remote unwinding support for macOS * Fix broken Win build by bumping minimum language requirement to C11 * Update license headers * Rename remote_unwind to remote * Revert Gparser.c
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dc12eb7e..245a41bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,8 @@ project(libunwind)
cmake_minimum_required(VERSION 3.16.1)
+set(CMAKE_C_STANDARD 11)
+
set(PKG_MAJOR "1")
set(PKG_MINOR "6")
set(PKG_EXTRA "-rc1")
@@ -50,7 +52,8 @@ if ("${CMAKE_GENERATOR}" MATCHES "^Visual Studio.*$")
add_compile_options(/permissive-)
# files for cross os compilation
- include_directories(include/win)
+ include_directories(include/remote)
+ include_directories(include/remote/win)
# Warnings in release builds
add_compile_options(-wd4068) # ignore unknown pragma warnings (gcc pragmas)
@@ -75,14 +78,14 @@ if ("${CMAKE_GENERATOR}" MATCHES "^Visual Studio.*$")
# Fake it until support is added
check_include_files(stdalign.h HAVE_STDALIGN_H)
if (NOT HAVE_STDALIGN_H)
- configure_file(include/win/fakestdalign.h.in ${CMAKE_CURRENT_BINARY_DIR}/include/stdalign.h)
+ configure_file(include/remote/win/fakestdalign.h.in ${CMAKE_CURRENT_BINARY_DIR}/include/stdalign.h)
endif (NOT HAVE_STDALIGN_H)
# MSVC compiler is currently missing C11 stdatomic.h header
# Fake it until support is added
check_include_files(stdatomic.h HAVE_STDATOMIC_H)
if (NOT HAVE_STDATOMIC_H)
- configure_file(include/win/fakestdatomic.h.in ${CMAKE_CURRENT_BINARY_DIR}/include/stdatomic.h)
+ configure_file(include/remote/win/fakestdatomic.h.in ${CMAKE_CURRENT_BINARY_DIR}/include/stdatomic.h)
endif (NOT HAVE_STDATOMIC_H)
# MSVC compiler is currently missing C11 _Thread_local