summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Jacobowitz <drow@false.org>2008-02-04 17:16:37 -0700
committerDavid Mosberger-Tang <davidm@koala.mostang.com>2008-02-04 17:16:37 -0700
commit3842dac7333e42aa44531eda34ba55200b99ccf8 (patch)
tree409f22e4ddf1c4711c106e88f529764420d7d89e /Makefile.am
parent5ed2da2a403fe091d953183449003c9df861c289 (diff)
downloadlibunwind-3842dac7333e42aa44531eda34ba55200b99ccf8.tar.gz
Add initial ARM and MIPS support. To support this, also enable the
reading of .debug_frame sections (used in lieu of .eh_frame sections when they're not available).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6b4e1d8b..0c68c6d1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,15 @@
+if ARCH_ARM
+include_HEADERS_tdep = include/libunwind-arm.h
+else
if ARCH_IA64
include_HEADERS_tdep = include/libunwind-ia64.h
else
if ARCH_HPPA
include_HEADERS_tdep = include/libunwind-hppa.h
else
+if ARCH_MIPS
+include_HEADERS_tdep = include/libunwind-mips.h
+else
if ARCH_X86
include_HEADERS_tdep = include/libunwind-x86.h
else
@@ -19,8 +25,10 @@ endif # ARCH_PPC64
endif # ARCH_PPC32
endif # ARCH_X86_64
endif # ARCH_X86
+endif # ARCH_MIPS
endif # ARCH_HPPA
endif # ARCH_IA64
+endif # ARCH_ARM
include_HEADERS_common = $(include_HEADERS_tdep) \
include/libunwind-dynamic.h include/libunwind-ptrace.h