summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOlivier Fourdan <ofourdan@redhat.com>2014-12-02 13:30:24 +0100
committerArun Sharma <arun@sharma-home.net>2014-12-04 00:12:00 -0800
commit6e3254ea6e6fa6c433cd38f9716a0b3b4110de64 (patch)
tree6f636a914578ce941bfb5cef84bd5c151db35e53 /Makefile.am
parent16e98c8cf37b006c3879ee57acc23c9af13c40d5 (diff)
downloadlibunwind-6e3254ea6e6fa6c433cd38f9716a0b3b4110de64.tar.gz
[PATCH] Fix build from scratch
- Add autogen.sh to bootstrap autotools generation - Make generation of man pages optional, and check for availibity of latex2man if documentation is requested. Signed-off-by: Olivier Fourdan <ofourdan@redhat.com> Signed-off-by: Arun Sharma <asharma@fb.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 98ae1ef2..6a3ed9e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,7 +42,11 @@ endif
nodist_include_HEADERS = include/libunwind-common.h
-SUBDIRS = src tests doc
+SUBDIRS = src tests
+
+if CONFIG_DOCS
+SUBDIRS += doc
+endif
noinst_HEADERS = include/dwarf.h include/dwarf_i.h include/dwarf-eh.h \
include/compiler.h include/libunwind_i.h include/mempool.h \