summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTommi Rantala <tt.rantala@gmail.com>2012-08-16 13:10:29 +0300
committerTommi Rantala <tt.rantala@gmail.com>2012-09-28 14:50:03 +0300
commit8d5b1aeeffb80515197fd7aeee0b3fbfac904ecd (patch)
tree70898dc1bf11f5e99a6cb32998eb734e579da8c0 /Makefile.am
parent7d77ef4d82b3eca8ca3a869cd313428026a122a7 (diff)
downloadlibunwind-8d5b1aeeffb80515197fd7aeee0b3fbfac904ecd.tar.gz
SuperH port
Add support for the 32bit SuperH architecture running Linux. Specifically, support is added for SH4, and support for earlier SH versions and to the 64bit SH5 are left out. This was tested in qemu with a little-endian SH4 debian image & GCC 4.7 cross compiler.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 00715b2a..8555f181 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,9 @@ endif
if ARCH_PPC64
include_HEADERS += include/libunwind-ppc64.h
endif
+if ARCH_SH
+include_HEADERS += include/libunwind-sh.h
+endif
if !REMOTE_ONLY
include_HEADERS += include/libunwind.h include/unwind.h
@@ -54,6 +57,8 @@ noinst_HEADERS = include/dwarf.h include/dwarf_i.h include/dwarf-eh.h \
include/tdep-ppc32/jmpbuf.h include/tdep-ppc32/libunwind_i.h \
include/tdep-ppc64/dwarf-config.h \
include/tdep-ppc64/jmpbuf.h include/tdep-ppc64/libunwind_i.h \
+ include/tdep-sh/dwarf-config.h \
+ include/tdep-sh/jmpbuf.h include/tdep-sh/libunwind_i.h \
include/tdep/libunwind_i.h \
include/tdep/jmpbuf.h include/tdep/dwarf-config.h