summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZhaofeng Li <hello@zhaofeng.li>2021-06-25 20:32:54 +0000
committerDave Watson <dade.watson@gmail.com>2021-07-06 11:49:20 -0700
commitabd15da8afb35b92ed0cb2c47f6564775b976c24 (patch)
treef68f51c6e7f91f1a78ace1646ddbc803dda4ecf6 /Makefile.am
parentbad872f653a31fd46fcbb64a60a266e26d7aaa77 (diff)
downloadlibunwind-abd15da8afb35b92ed0cb2c47f6564775b976c24.tar.gz
Add port for Linux on RISC-V (riscv)
This commit adds support for Linux on RISC-V. Only 64-bit is supported at the moment.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 072decf1..9bb2413d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,6 +44,9 @@ endif
if ARCH_S390X
include_HEADERS += include/libunwind-s390x.h
endif
+if ARCH_RISCV
+include_HEADERS += include/libunwind-riscv.h
+endif
if !REMOTE_ONLY
include_HEADERS += include/libunwind.h
@@ -92,6 +95,8 @@ noinst_HEADERS = include/dwarf.h include/dwarf_i.h include/dwarf-eh.h \
include/tdep-sh/jmpbuf.h include/tdep-sh/libunwind_i.h \
include/tdep-s390x/dwarf-config.h \
include/tdep-s390x/jmpbuf.h include/tdep-s390x/libunwind_i.h \
+ include/tdep-riscv/dwarf-config.h \
+ include/tdep-riscv/jmpbuf.h include/tdep-riscv/libunwind_i.h \
include/tdep/libunwind_i.h \
include/tdep/jmpbuf.h include/tdep/dwarf-config.h