summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-27 16:45:00 +0000
committerDave Watson <dade.watson@gmail.com>2021-11-30 16:26:08 -0800
commit4c01eb4107a0cc69bd35a5f3ed70bfb754fdc311 (patch)
tree8febcc8e3fd563729228744dcb9e424935500e6a /configure.ac
parentaf5e6d3ab3d8f8ba8cc955b6ed70712e2165c9ad (diff)
downloadlibunwind-4c01eb4107a0cc69bd35a5f3ed70bfb754fdc311.tar.gz
configure.ac: avoid bashisms
configure scripts need to be written in POSIX-compliant shell; using '==' is a Bashism (doesn't work for POSIX-compliant shells). Let's use '=' as we do elsewhere to fix compatibility. Fixes: #313 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c329beba..b8d81135 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,7 +137,7 @@ AC_MSG_RESULT([$enable_ptrace])
AC_ARG_ENABLE(setjmp,
AS_HELP_STRING([--enable-setjmp],[building libunwind-setjmp library]),,
- [AS_IF([test x$target_arch == x$host_arch], [enable_setjmp=yes], [enable_setjmp=no])]
+ [AS_IF([test x$target_arch = x$host_arch], [enable_setjmp=yes], [enable_setjmp=no])]
)
AC_ARG_ENABLE(documentation,
@@ -264,7 +264,7 @@ case "${target_arch}" in
(aarch64) enable_debug_frame=yes;;
(*) enable_debug_frame=no;;
esac])
-if test x$remote_only == xyes; then
+if test x$remote_only = xyes; then
enable_debug_frame=no
fi
if test x$enable_debug_frame = xyes; then