summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Fischer <matt.fischer@garmin.com>2013-04-18 18:32:53 -0500
committerMatt Fischer <matt.fischer@garmin.com>2013-04-19 17:08:03 -0500
commit563b0ff3144c0e60a9aa63fdafb4dea66ecd3d50 (patch)
tree17978c623d70fb6675bf086a0e1d6cf39a869a8d /configure.ac
parentabb0957198be8cb34c4dfa0dfd7e7eee13055f09 (diff)
downloadlibunwind-563b0ff3144c0e60a9aa63fdafb4dea66ecd3d50.tar.gz
Added --enable-setjmp
Currently, libunwind-setjmp is built whenever local unwinding is built. This patch adds an explicit flag to control it instead. The default if not specified is to follow the old behavior.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b68c1c22..f7e95ad7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,6 +118,14 @@ AC_ARG_ENABLE(ptrace,
AC_MSG_CHECKING([if we should build libunwind-ptrace])
AC_MSG_RESULT([$enable_ptrace])
+AC_ARG_ENABLE(setjmp,
+ AS_HELP_STRING([--enable-setjmp],[building libunwind-setjmp library]),,
+ [AS_IF([test x$target_arch == x$host_arch], [enable_setjmp=yes], [enable_setjmp=no])]
+)
+
+AC_MSG_CHECKING([if we should build libunwind-setjmp])
+AC_MSG_RESULT([$enable_setjmp])
+
AC_MSG_CHECKING([for build architecture])
AC_MSG_RESULT([$build_arch])
AC_MSG_CHECKING([for host architecture])
@@ -129,6 +137,7 @@ AC_MSG_RESULT([$target_os])
AM_CONDITIONAL(BUILD_COREDUMP, test x$enable_coredump = xyes)
AM_CONDITIONAL(BUILD_PTRACE, test x$enable_ptrace = xyes)
+AM_CONDITIONAL(BUILD_SETJMP, test x$enable_setjmp = xyes)
AM_CONDITIONAL(REMOTE_ONLY, test x$target_arch != x$host_arch)
AM_CONDITIONAL(ARCH_ARM, test x$target_arch = xarm)
AM_CONDITIONAL(ARCH_IA64, test x$target_arch = xia64)