summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Fleytman <dfleytma@redhat.com>2016-01-20 17:05:55 +0200
committerChris Dickens <christopher.a.dickens@gmail.com>2016-01-26 23:38:23 -0800
commit24c528934236fd167adc162695a5bdbd60bf7842 (patch)
treed15ef7c64c74bb959a65299f85da1a020249ca7d /configure.ac
parent8823c17024c59984c2dcf5870e27ab3a023428b9 (diff)
downloadlibusb-24c528934236fd167adc162695a5bdbd60bf7842.tar.gz
build: Integrate usbdk backend
Signed-off-by: Dmitry Fleytman <dfleytma@redhat.com> Signed-off-by: Chris Dickens <christopher.a.dickens@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 244cd41..ec71e62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,6 +172,14 @@ windows)
LTLDFLAGS="${LTLDFLAGS} -avoid-version -Wl,--add-stdcall-alias"
AC_DEFINE([POLL_NFDS_TYPE],[unsigned int],[type of second poll() argument])
AC_DEFINE([WINVER], 0x0501, [Oldest Windows version supported])
+
+ AC_ARG_ENABLE([usbdk],
+ [AC_HELP_STRING([--enable-usbdk], [use UsbDk Windows backend [default=no]])],
+ [], [enable_usbdk="no"])
+ if test "x$enable_usbdk" = "xyes" ; then
+ AC_DEFINE(USE_USBDK, 1, [Use UsbDk Windows backend])
+ fi
+ AC_SUBST(USE_USBDK)
;;
haiku)
AC_DEFINE(OS_HAIKU, 1, [Haiku backend])
@@ -193,6 +201,7 @@ AM_CONDITIONAL(OS_HAIKU, test "x$backend" = xhaiku)
AM_CONDITIONAL(THREADS_POSIX, test "x$threads" = xposix)
AM_CONDITIONAL(CREATE_IMPORT_LIB, test "x$create_import_lib" = "xyes")
AM_CONDITIONAL(USE_UDEV, test "x$enable_udev" = xyes)
+AM_CONDITIONAL(USE_USBDK, test "x$enable_usbdk" = xyes)
if test "$threads" = posix; then
AC_DEFINE(THREADS_POSIX, 1, [Use POSIX Threads])
fi