summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTormod Volden <debian.tormod@gmail.com>2022-02-10 18:43:23 +0100
committerTormod Volden <debian.tormod@gmail.com>2022-03-16 17:53:00 +0100
commitf9162d36bf7253b3743d2973e385d32166ea0795 (patch)
tree3af30036d3f57a30e4c57fda46cca9f6541bc9ac /configure.ac
parent670f75f046f6f431255ab8836a4e63f877c64d2c (diff)
downloadlibusb-f9162d36bf7253b3743d2973e385d32166ea0795.tar.gz
windows: Link gcc helpers statically on MinGW
Fixes #1049 Signed-off-by: Tormod Volden <debian.tormod@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 002bcf6..7dd7dd4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,6 +124,7 @@ case $host in
platform=windows
test "x$enable_shared" = xyes && create_import_lib=yes
EXTRA_CFLAGS="-mwin32 -fno-omit-frame-pointer"
+ EXTRA_LDFLAGS="-static-libgcc"
;;
*)
AC_MSG_RESULT([Null])
@@ -394,6 +395,8 @@ AC_SUBST(AM_CXXFLAGS)
AC_SUBST(LT_LDFLAGS)
+AC_SUBST([EXTRA_LDFLAGS])
+
dnl set name of html output directory for doxygen
AC_SUBST(DOXYGEN_HTMLDIR, [api-1.0])