summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNathan Hjelm <hjelmn@google.com>2023-04-03 09:55:25 -0600
committerNathan Hjelm <hjelmn@google.com>2023-04-12 13:02:35 -0600
commit84ac0b0f60323fab7ae765b2119df6149968b6e2 (patch)
tree9040b7f5c36987fc3c59c1ef40c55c5839e9dc16 /tests/Makefile.am
parentfcf0c710ef5911ae37fbbf1b39d48a89f6f14e8a (diff)
downloadlibusb-84ac0b0f60323fab7ae765b2119df6149968b6e2.tar.gz
Add support for setting the log callback with libusb_set_option/libusb_init_context
This commit effectively deprecates libusb_set_log_cb by adding support for setting the callback in either libusb_set_option or libusb_init_context. Since the libusb_set_log_cb is already in use we can not easily deprecate it without first incrementing the major version. We may do that in the future. Closes #1265 Signed-off-by: Nathan Hjelm <hjelmn@google.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7831494..94ed32c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,9 +5,10 @@ LIBS =
stress_SOURCES = stress.c testlib.c
stress_mt_SOURCES = stress_mt.c
set_option_SOURCES = set_option.c testlib.c
+init_context_SOURCES = init_context.c testlib.c
noinst_HEADERS = libusb_testlib.h
-noinst_PROGRAMS = stress stress_mt set_option
+noinst_PROGRAMS = stress stress_mt set_option init_context
if BUILD_UMOCKDEV_TEST
# NOTE: We add libumockdev-preload.so so that we can run tests in-process