summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAustin Yuan <shengquan.yuan@intel.com>2009-11-09 09:57:32 +0800
committerAustin Yuan <shengquan.yuan@intel.com>2009-11-09 09:57:32 +0800
commit58f8cc670913b3338181136b5f7a865e0895cc04 (patch)
tree8ec9e6a65dfa5a71f8b6c9890b71f676767d11be /Makefile.am
parent49f5210a0aa8d60000a91f69d7f8ad4a682cad53 (diff)
downloadlibva-20091109_5.1.0.0127.tar.gz
merge master->local-branch-testing2ww46.1-beta-rc220091109_5.1.0.0127
Signed-off-by: Austin Yuan <shengquan.yuan@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5470b69..07385e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,9 +21,21 @@
# SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = src dummy_drv_video test
+
+SUBDIRS = src test
+if BUILD_DUMMY_DRIVER
+SUBDIRS += dummy_drv_video
+endif
+if BUILD_I965_DRIVER
+SUBDIRS += i965_drv_video
+endif
+
+pcfiles = libva.pc
+pcfiles += libva-x11.pc
pkgconfigdir = @pkgconfigdir@
-pkgconfig_DATA = libva.pc
+pkgconfig_DATA = $(pcfiles)
+
+EXTRA_DIST = libva.pc.in libva-x11.pc.in
-EXTRA_DIST = libva.pc.in
+CLEANFILES = $(pcfiles)