summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gbeauchesne@splitted-desktop.com>2009-07-08 07:50:01 +0000
committerAustin Yuan <shengquan.yuan@intel.com>2009-07-08 17:42:05 +0800
commit3cc18d820a60748c1c19fa5f4a388d9c05013392 (patch)
tree4b7f03a4245b96d596791eb43b09e4d5d0f9c99d /Makefile.am
parent3b10124ce0a3ce533f65bf613cbb6ef340f90c42 (diff)
downloadlibva-3cc18d820a60748c1c19fa5f4a388d9c05013392.tar.gz
Allow conditional build of video drivers (dummy, i965).
Signed-off-by: Austin Yuan <shengquan.yuan@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3515b69..d1c7cce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,14 @@
# SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = src dummy_drv_video i965_drv_video test
+
+SUBDIRS = src test
+if BUILD_DUMMY_DRIVER
+SUBDIRS += dummy_drv_video
+endif
+if BUILD_I965_DRIVER
+SUBDIRS += i965_drv_video
+endif
pkgconfigdir = @pkgconfigdir@
pkgconfig_DATA = libva.pc