summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSean V Kelley <seanvk@posteo.de>2017-02-01 10:10:35 -0800
committerSean V Kelley <seanvk@posteo.de>2017-02-01 10:33:44 -0800
commitc753468542a3e1405fc8e316d078fb7ae9757d67 (patch)
tree52d4af92f0b30376c53db18f75683a16353ee013 /Makefile.am
parent929d90f55b8226e78b9fb76e09c8dbb94f8c4cd9 (diff)
downloadlibva-c753468542a3e1405fc8e316d078fb7ae9757d67.tar.gz
debian: Remove legacy packaging
debian control files are maintained by packagers Yes there is a "convenience" factor to roll your own debian package, but this is not maintained by us and represents a fork from debian packagers. As with the bit rot of libva.spec, remove this. fixes #18 Signed-off-by: Sean V Kelley <seanvk@posteo.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 1 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index be1ce9e..2eced8a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,24 +24,10 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = va dummy_drv_video pkgconfig debian.upstream doc
+SUBDIRS = va dummy_drv_video pkgconfig doc
# Extra clean files so that maintainer-clean removes *everything*
MAINTAINERCLEANFILES = \
aclocal.m4 compile config.guess config.sub \
configure depcomp install-sh ltmain.sh \
Makefile.in missing
-
-DEB_BUILDDIR = debian.build
-
-deb:
- @[ -d debian ] || ln -s debian.upstream debian
- dpkg-buildpackage -rfakeroot -uc -us
-
-deb.upstream: dist
- -mkdir -p $(DEB_BUILDDIR)
- cd $(DEB_BUILDDIR) && \
- rm -rf $(PACKAGE)-$(VERSION) && \
- tar zxvf ../$(PACKAGE)-$(VERSION).tar.gz && \
- cd $(PACKAGE)-$(VERSION) && \
- $(MAKE) deb -f Makefile.am