summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Olbrich <m.olbrich@pengutronix.de>2019-10-02 20:07:41 +0200
committerXinfengZhang <carl.zhang@intel.com>2019-10-09 12:02:43 +0800
commit06f023e84b407a2fe429191aa081f3cc81bb6445 (patch)
tree2a0731888891d42ef312e203bc722b8d7a700211 /configure.ac
parentd49b99d5d88f66e2e1ca451cf19251c7950c870d (diff)
downloadlibva-06f023e84b407a2fe429191aa081f3cc81bb6445.tar.gz
configure: use correct comparison operator
'==' is invalid posix shell syntax. With dash as /bin/sh the check fails with: ./configure: 17656: test: yes: unexpected operator Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d109aee..acb4c79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -259,7 +259,7 @@ if test "$USE_X11:$enable_glx" = "no:yes"; then
AC_MSG_ERROR([VA/GLX explicitly enabled, but VA/X11 isn't built])
fi
-if test "$USE_X11" == "yes" -a "$enable_glx" != "no"; then
+if test "$USE_X11" = "yes" -a "$enable_glx" != "no"; then
PKG_CHECK_MODULES([GLX], [gl x11], [USE_GLX="yes"], [:])
saved_CPPFLAGS="$CPPFLAGS"
saved_LIBS="$LIBS"