summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHaihao Xiang <haihao.xiang@intel.com>2019-04-09 11:11:16 +0800
committerXinfengZhang <carl.zhang@intel.com>2019-04-16 11:46:24 +0800
commit4d9d819d4859bf2fe2554d2619ddbf21cbedb90c (patch)
treedee2d4b382f0cd5e309cb6c6988f65c2556628bf /configure.ac
parent6724011e8b52901f13dded130f0b47e8bdbd4dda (diff)
downloadlibva-4d9d819d4859bf2fe2554d2619ddbf21cbedb90c.tar.gz
configure: don't build glx if VA/X11 isn't built2.5.0.pre1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bbb8370..7942f57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -259,7 +259,7 @@ if test "$USE_X11:$enable_glx" = "no:yes"; then
AC_MSG_ERROR([VA/GLX explicitly enabled, but VA/X11 isn't built])
fi
-if test "$USE_X11:$enable_glx" != "yes:no"; then
+if test "$USE_X11" == "yes" -a "$enable_glx" != "no"; then
PKG_CHECK_MODULES([GLX], [gl x11], [USE_GLX="yes"], [:])
saved_CPPFLAGS="$CPPFLAGS"
saved_LIBS="$LIBS"